Задать вопрос
22 января, 20:27

Решить в паскале задачу (8-9 класс) :

дано четырехзначное число. определить, входят ли в него цифры 2 или 7

+1
Ответы (1)
  1. 22 января, 23:08
    0
    program test;

    var x, temp: integer; flag: boolean;

    begin

    write ('Введите целое четырёхзначное число: ') ;

    read (x) ;

    flag:=false;

    while x 0 do

    begin

    temp:=x mod 10;

    if (temp = 2) or (temp = 7) then

    begin

    flag:=true;

    break;

    end;

    x:=x div 10;

    end;

    if flag then

    writeln ('2 или 7 входят в число.')

    else

    writeln ('2 или 7 не входят в число.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в паскале задачу (8-9 класс) : дано четырехзначное число. определить, входят ли в него цифры 2 или 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1. дано натурально четырехзначное число. определить цифры этого числа (K, L. M. N) и выяснить можно ли построить ромб со сторонами K, L. M. N. в паскале АВС. 2. дано натурально число N вычислить куб суммы этого числа
Ответы (1)
Дано четырехзначное число n. Выписать число в обратном порядке. n - четырехзначное число (1762) - исходные данные a, b, c, d - цифры этого числа (вспомогательные переменные). m - обратное число (результат) Решить через div и mod
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)