Задать вопрос
8 октября, 21:14

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

+1
Ответы (1)
  1. 8 октября, 21:37
    0
    Program task1;

    var number, max, min, ost, digit : integer;

    begin

    readln (number) ; max: = 0; min: = 9; while number > 0 do begin digit: = number mod 10; if digit max then max: = digit; number: = number div 10; end; writeln ('Минимальная цифра: ', min) ; writeln ('Максимальная цифра: ', max) ;

    end.

    program task2;

    var number, digit, sum, p : integer;

    begin

    readln (number) ; sum: = 0; p: = 1; while number > 0 do begin digit: = number mod 10; sum: = sum + digit; p: = p * digit; number: = number div 10; end; sum: = sum * 3; if sum > p then writeln ('Утроенная сумма больше произведения') ; if p > sum then writeln ('Произведение больше утроенного произведения') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите написать программу))) Задано трехзначное число, определить: 1) сумму цифр этого числа; 2) произведение; 3) минимальную цифру; 4) максимальную цифру этого числа.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)