Задать вопрос
19 июня, 13:38

Помогите написать программу)))

Задано трехзначное число, определить:

1) сумму цифр этого числа;

2) произведение;

3) минимальную цифру;

4) максимальную цифру этого числа.

+5
Ответы (1)
  1. 19 июня, 16:14
    0
    Uses crt;

    var a, b, c, x, max, min, sum, pr: integer;

    begin

    write ('Введите число: ') ;

    readln (x) ;

    a: = x div 100;

    b: = x div 10 mod 10;

    c: = x mod 10;

    sum:=a+b+c;

    pr:=a*b*c;

    if a>b then begin

    min:=b;

    max:=a;

    end

    else begin

    max:=b;

    min:=a;

    end;

    if min>c then min:=c;

    if max
    writeln ('Сумма цифр числа: ', sum) ;

    writeln ('Произведение цифр числа: ', pr) ;

    writeln ('Максимальная цифра: ', max) ;

    writeln ('Минимальная цифра: ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу))) Задано трехзначное число, определить: 1) сумму цифр этого числа; 2) произведение; 3) минимальную цифру; 4) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)