Задать вопрос
20 ноября, 23:17

На паскале нужно решить задачи

1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа.

2. Задано трехзначное число. Составьте программу, с помощью которой определите, равняются ли в нем крайние числа.

+2
Ответы (1)
  1. 21 ноября, 01:34
    0
    var

    a, e, d, s, p: integer;

    begin

    p:=1;

    writeln ('введи трехзначное число') ;

    read (a) ;

    e: = (a mod 10) ;

    s: = (a div 100) ;

    d:=s*100-e;

    p:=s*s*s*d*d*d*e*e*e;

    writeln ('произведение кубов цифр числа равно', p) ;

    if e=s then writeln ('первая цифра числа равна последней')

    else

    writeln ('первая цифра числа не равна последней') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Если трёхзначное число равно сумме кубов цифр, образующих это число, то такое число называется "магическим". Найти и вывести все "магические числа". (Написать функцию вычисления суммы кубов цифр трёхзначного числа).
Ответы (1)