Задать вопрос
9 мая, 15:16

Написать программу, которая в одномерном массиве из 15 элементов подсчитывает количество элементов равных среднеарифметическому

+5
Ответы (1)
  1. 9 мая, 18:09
    0
    Uses crt;

    const

    n=15;

    var

    a:array[1 ... n]of real;

    i, k:integer;

    s:real;

    begin

    for i:=1 to n do

    begin

    readln (a[i]) ;

    s:=s+a[i];

    end;

    s:=s/n;

    writeln;

    clrscr;

    for i:=1 to n do

    begin

    write (a[i]:6:2) ;

    if a[i]=s then

    inc (k) ;

    end;

    writeln;

    if k0 then

    writeln ('k: ', k)

    else writeln ('Нет равных')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая в одномерном массиве из 15 элементов подсчитывает количество элементов равных среднеарифметическому ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. Написать программу, которая подсчитывает периметр квадрата, площадь которого равна а. 2. Написать программу, которая подсчитывает площадь равностороннего треугольника, периметр которого равен p
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)