Задать вопрос
10 февраля, 22:02

1) составить блок схему и программу для вычисления y и z по заданным формулам

Y=2e^4x+arctg (x/a), при a=5.1

Z=cosx^3+sin^2x, при x=3,29

2) Создать новый одномерный массив B из элементов исходной матрицы А (6,8), удовлетворяющие условию 0≤cosa<0,5. В полученном массиве поменять местами максимальные и минимальные

+5
Ответы (1)
  1. 10 февраля, 22:57
    0
    Const

    a=5.1;

    x=3.29;

    var

    Y, Z:double;

    begin

    Y:=2*exp (4*x) + arctan (x/a) ;

    Z:=cos (x*sqr (x)) + sqr (sin (x)) ;

    Writeln ('Y=', Y,', Z=', Z)

    end.

    Результат выполнения программы:

    Y=1038354.42291114, Z=-0.472433980670957

    const

    m=6;

    n=8;

    var

    a:array[1 ... m, 1 ... n] of double;

    b:array[1 ... m*n] of double;

    i, j, k, imax, imin:integer;

    t:double;

    begin

    / / Инициализация А и формирование В

    Randomize;

    Writeln ('Исходный массив A') ;

    k:=0;

    for i:=1 to m do begin

    for j:=1 to n do begin

    a[i, j]:=10*Random-5; { случайное число на [-5; 5] }

    Write (a[i, j]:8:4) ;

    t:=cos (a[i, j]) ;

    if (t>=0) and (t<0.5) then begin Inc (k) ; b[k]:=a[i, j] end

    end;

    Writeln

    end;

    / / Вывод сформированного массива В

    Writeln ('Исходный массив В') ;

    for i:=1 to k do Write (b[i]:8:4) ;

    Writeln;

    / / Поиск максимума и минимума с последующим обменом их местами

    imax:=1; imin:=1;

    for i:=2 to k do

    if b[i]
    else

    if b[i]>b[imax] then imax:=i;

    t:=b[imax]; b[imax]:=b[imin]; b[imin]:=t;

    / / Вывод результирующего массива В

    Writeln ('Результирующий массив В') ;

    for i:=1 to k do Write (b[i]:8:4) ;

    Writeln

    end.

    Тестовое решение:

    Исходный массив A

    -1.6788 - 0.7273 - 3.4919 2.9903 - 4.3249 - 2.2230 - 2.1157 0.9685

    2.0515 4.6821 0.2794 - 1.4624 4.9668 - 3.5754 - 3.4115 - 0.5592

    3.0535 1.1339 0.0992 - 0.5307 - 0.6266 2.2623 1.9578 - 1.3175

    -0.6154 3.6080 2.4223 - 4.8354 - 2.2978 3.8982 - 2.2427 2.0410

    -1.1019 - 3.4703 - 2.0104 - 1.3044 0.7744 0.6897 3.1747 1.3257

    -4.3942 - 1.6707 - 3.2494 - 0.6551 3.4726 - 0.2896 3.4154 1.9644

    Исходный массив В

    -1.4624 4.9668 1.1339 - 1.3175 - 4.8354 - 1.1019 - 1.3044 1.3257

    Результирующий массив В

    -1.4624 - 4.8354 1.1339 - 1.3175 4.9668 - 1.1019 - 1.3044 1.3257
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) составить блок схему и программу для вычисления y и z по заданным формулам Y=2e^4x+arctg (x/a), при a=5.1 Z=cosx^3+sin^2x, при x=3,29 2) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Напишите программу на языке Pascal. Элементы массива А, удовлетворяющие условию А (i) >5.5, переписать в массив В, а элементы, удовлетворяющие условию А (i)
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)