Задать вопрос
18 июля, 15:39

Напишите программу на языке Pascal. Элементы массива А, удовлетворяющие условию А (i) >5.5, переписать в массив В, а элементы, удовлетворяющие условию А (i) <=5.5, переписать в массив С. В массиве А m элементов.

+4
Ответы (1)
  1. 18 июля, 18:30
    0
    var

    A, B, C: array[1 ... 100] of integer;

    i, n, j, k:integer;

    begin

    randomize;

    j:=0;

    k:=0;

    Readln (n) ;

    Writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    A[i]:=random (10) ;

    writeln ('A[', i,']=', A[i]) ;

    end;

    for i:=1 to n do

    if A[i]>5.5

    then

    begin

    j:=j+1;

    B[j]:=A[i];

    end;

    for i:=1 to n do

    if A[i]<=5.5

    then

    begin

    K:=k+1;

    C[k]:=A[i];

    end;

    for i:=1 to j do

    writeln ('B[', i,']=', B[i]) ;

    for i:=1 to k do

    writeln ('C[', i,']=', C[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке Pascal. Элементы массива А, удовлетворяющие условию А (i) >5.5, переписать в массив В, а элементы, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)