Задать вопрос
28 мая, 11:46

Написать программу, которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. Если исходное число больше 0

+4
Ответы (2)
  1. 28 мая, 12:00
    0
    Var a, b, c:integer;

    begin

    writeln ('введите число') ;

    readln (a) ;

    if a<0 then b:=a+7 else b:=a-2;

    if a=0 then while a=0 do begin writeln ('введите другое число') ; end;

    writeln ('полученное число ', b) ;

    end.
  2. 28 мая, 15:14
    0
    var x : real;

    begin

    writeln ('Введите число : ') ;

    readln (x) ;

    if (x<0) then x:=x+7

    else if (x>0) then x:=x-2;

    writeln (' Конечное число : ', x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. Если исходное число больше 0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное
Ответы (1)
Помогите! Паскаль. Исполнитель "Раздвоитель" преобразует натуральные числа. У него есть две команды: "Вычесть 1" и "Разделить на 2", первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит
Ответы (1)
1) Дано целое число N. Написать программу, заменяющую его 1, если число меньше нуля, и увеличивающую его на 6, если число больше или равно нулю. 2) Даны два числа a и b. Написать программу, которая выводит номер большего из них
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Дано целое число написать программу выводящую ноль если число меньше нуля или без изменений если больше нуля
Ответы (1)