Задать вопрос
25 мая, 08:02

Помогите! Паскаль. Исполнитель "Раздвоитель" преобразует натуральные числа. У него есть две команды: "Вычесть 1" и "Разделить на 2", первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.

+4
Ответы (1)
  1. 25 мая, 09:21
    0
    Var a, b : integer;

    begin

    readln (a, b) ;

    while a b do

    begin

    if (a > = b * 2) and (a mod 2 = 0) then

    begin

    a : = round (a / 2) ;

    writeln (':2') ;

    end

    else

    begin

    a : = a - 1;

    writeln (-1) ;

    end

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! Паскаль. Исполнитель "Раздвоитель" преобразует натуральные числа. У него есть две команды: "Вычесть 1" и "Разделить на 2", первая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У исполнителя Делитель две команды, которым присвоены номера: 1. раздели на 2 2. вычти 1 Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1. Исполнитель работает только с натуральными числами.
Ответы (1)
Исполнителя Делитель две команды, которым присвоены номера: 1. раздели на 2 2. вычти 3 Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 3. Исполнитель работает только с натуральными числами.
Ответы (1)
У исполнителя Делитель две команды, которым присвоены номера: 1. раздели на 2 2. вычти 3 Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 3. Исполнитель работает только с натуральными числами.
Ответы (1)
У исполнителя Делитель 2 команды, к-ым присвоены номера: 1. раздели на 2 2. вычти 1 Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1. Исполнитель работает только с натур. числами.
Ответы (1)
Исполнитель Прибавитель преобразует число на экране. У исполнителя две команды, которым присвоены номера: 1. Прибавить 1 2.
Ответы (1)