Задать вопрос
20 апреля, 19:28

Найдите сумму элементов четных и сумму нечетных строк

матрицы А (n, m)

+2
Ответы (1)
  1. 20 апреля, 20:55
    0
    Const n=5; m=5;

    var a: array [1 ... n, 1 ... m] of integer;

    i, j, s, s_:integer;

    begin

    writeln ('Исходная матрица: ') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (15) + 1;

    if (i mod 2) = 0 then

    s:=s+a[i, j]

    else

    s_:=s_+a[i, j];

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    writeln;

    writeln ('Сумма чётных строк: ', s) ;

    writeln ('Сумма не чётных строк: ', s_) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите сумму элементов четных и сумму нечетных строк матрицы А (n, m) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)