Задать вопрос
5 октября, 20:49

Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.

+1
Ответы (1)
  1. 5 октября, 21:02
    0
    var

    a, b, c, g : integer;

    / / a, b, c - стороны

    begin

    readln (a, b, c) ;

    / / g - находим гипотенузу (наибольшее из чисел)

    if a > b then

    begin

    if a > c then

    g : = a

    else

    g : = c

    end

    else

    if b > c

    then

    g : = b

    else

    g : = c;

    / / Если треугольник прямоугольный, то

    / / сумма квадратов катетов равна квадрату гипотенузы

    if (sqr (a) + sqr (b) = sqr (g))

    or (sqr (a) + sqr (c) = sqr (g)) then

    writeln ('Yes')

    else writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
с клавиатуры вводят слово. Составить программу, которая: а) определяет количество символов в нём б) проверяет, не совпадают ли первая и последняя буквы слова в) выводт на экран первый, второй и последний символы г) определяет, чётно или нечётно
Ответы (1)