Задать вопрос
6 мая, 19:00

с клавиатуры вводят слово. Составить программу, которая:

а) определяет количество символов в нём

б) проверяет, не совпадают ли первая и последняя буквы слова

в) выводт на экран первый, второй и последний символы

г) определяет, чётно или нечётно количество символов в нём

+2
Ответы (1)
  1. 6 мая, 20:10
    0
    uses crt;

    var s: string;

    begin

    writeln ('Напишите слово') ;

    readln (s) ;

    writeln (length (s),' символов') ;

    writeln (s[1],' первый символ ', s[2],' второй символ ', s[length (s) ],' последний символ') ;

    if (s[length (s) ] = s[1]) then

    begin

    writeln ('совпадают') ;

    end

    else writeln ('не совпадают') ;

    if (length (s) mod 2 = 0) then

    begin

    writeln ('четное кол-во') ;

    end

    else writeln ('не четное') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «с клавиатуры вводят слово. Составить программу, которая: а) определяет количество символов в нём б) проверяет, не совпадают ли первая и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводят число. Составить программу которая: а) Определяет количество символов в нём; б) проверяет, не совпадают ли первая и последняя буква слова; в) выводит на экран первый, второй и последний символы;
Ответы (1)
С клавиатуры вводят слово. Составить программу, которая определяет, чётно или нечётно количество символов в слове
Ответы (1)
С клавиатуры вводят слово. составить программу, которая выводит на экран первый, второй и последний символы
Ответы (1)
помогите решить задачю по информатике С клавиатуры последовательно вводят целые числа и высчитывается их сумма если с клавиатуры вводят 0, то больше числа не вводят. Найти сумму всех введеных чисел.
Ответы (1)
Программа спрашивает у пользователя слово и выводит на экран все его буквы до середины (не включая среднюю букву, если число букв нечётно), а вторую половину (начиная со средней буквы, если число букв нечётно), выводит на экран задом наперёд.
Ответы (1)