Задать вопрос
23 февраля, 17:01

Составить программу, выводящую на экран сведения о

периодических изданиях (наименование издания, тираж, годовая стоимость).

Сначала вывести сведения, отсортированные по возрастанию тиража, затем вывести

сведения, отсортированные по

наименованию по алфавиту.

+3
Ответы (1)
  1. 23 февраля, 18:28
    0
    Var

    i, k, n, j, z, x:integer;

    b, c, d:array[1 ... 10000] of integer;

    a, e:array[1 ... 10000] of string;

    m:string;

    begin

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ;

    readln (b[i]) ;

    readln (c[i]) ;

    for i:=1 to n do

    for j:=1 to n do

    if b[i]
    m:=a[i]; a[i]:=a[j]; a[j]:=m;

    z:=b[i]; b[i]:=b[j]; b[j]:=z;

    x:=c[i]; c[i]:=c[j]; c[j]:=x;

    end;

    for i:=1 to n do

    writeln (a[i],' ', b[i],' ', c[i]) ; {это сортировка по тиражу}

    for i:=1 to n do begin

    e[i]:=copy (a[i], 1, 2) ; {тут расчет на то, что название начинается с заглавной буквы английского алфавита}

    val (e[i], d[i]) ; end;

    for i:=1 to n do

    for j:=1 to n do

    if d[i]
    m:=a[i]; a[i]:=a[j]; a[j]:=m;

    z:=b[i]; b[i]:=b[j]; b[j]:=z;

    x:=c[i]; c[i]:=c[j]; c[j]:=x;

    end;

    for i:=1 to n do

    writeln (a[i],' ', b[i],' ', c[i]) ; {сортировка по тиражу}

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, выводящую на экран сведения о периодических изданиях (наименование издания, тираж, годовая стоимость). Сначала вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%", если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.
Ответы (1)