Задать вопрос
29 мая, 21:58

Сколько элементов массива размерностью N на M больше заданного числа R. Подсчитать среднее арифметическое этих элементов.

+3
Ответы (1)
  1. 30 мая, 01:30
    0
    Const N = 5; M = 10; var a: array [1 ... N, 1 ... M] of real; s, R: real; kol, i, j: integer; / / kol - количество чисел begin writeln ('Введите R') ; readln (R) ; for i: = 1 to N do for j: = 1 to M do begin writeln ('Введите a[', i, ', ', j, ']') ; readln (a[i, j]) ; if a[i, j] > R then begin kol: = kol + 1; s: = s + a[i, j]; end; end; s: = s / kol; writeln (kol, ' чисел > ', R) ; writeln ('Среднее арифметическое равно ', s) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько элементов массива размерностью N на M больше заданного числа R. Подсчитать среднее арифметическое этих элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)