Задать вопрос
1 мая, 00:25

Напишите программу для решения следующей задачи.

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

+1
Ответы (1)
  1. 1 мая, 01:05
    0
    Var N, i, k, z:integer;

    s:real;

    begin

    s:=0;

    k:=0;

    repeat

    write ('Введите кол-во дней : ') ;

    readln (N) ;

    until (N>=1) and (N<=31) ; {проверка на верное количество дней}

    for i:=1 to N do

    begin

    write ('Введите значение температуры в ', i,' день : ') ;

    readln (z) ;

    s:=s+z;

    if z>0 then k:=k+1;

    end;

    s:=s/N;

    writeln ('Средняя температура = ', s) ;

    if k>=5 then writeln ('YES') else writeln ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для Паскаль Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней.
Ответы (1)
Написать программу для Паскаль Найдите самую низкую температуру за время наблюдения, если температура опускалась нижу 15 градусов, выведите да, иначе - нет. Программа получает на входе количество дней, а для каждого дня вводится температура.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу для решения следующей задачи в qbasic Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)