Задать вопрос
30 января, 06:29

Напишите программу для решения следующей задачи в qbasic

Девятиклассники участвовали в викторине по математике. Необходимо было

ответить на 20 вопросов. Победителем викторины считается участник,

правильно ответивший на наибольшее количество вопросов. На сколько

вопросов победитель ответил правильно? Если есть участники викторины,

которые не смогли дать правильный ответ ни на один из вопросов, выведите

YES, иначе выведите NO. Гарантируется, что есть участники, правильно

ответившие хотя бы на один из вопросов.

Программа получает на вход число участников викторины N (1 ≤ N ≤ 50),

затем для каждого участника вводится количество вопросов, на которые

получен правильный ответ.

Пример работы программы:

Входные данные

4

15

12

0

17

Выходные данные

17

YES

+2
Ответы (1)
  1. 30 января, 09:52
    0
    var

    i, k, n, max: integer;

    f:boolean;

    begin

    readln (k) ;

    for i : = 1 to k do

    begin

    readln (n) ;

    if (i = 1) or (max < n) then

    max : = n;

    f:=f or (n=0) ;

    end;

    writeln (max,' ', f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для решения следующей задачи в qbasic Девятиклассники участвовали в викторине по математике. Необходимо было ответить на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)