Задать вопрос
22 марта, 19:40

Написать программу для Паскаль

Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. Программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.

+4
Ответы (1)
  1. 22 марта, 22:50
    0
    var

    m, k, d1: single;

    i, t, d: byte;

    begin

    readln (t) ;

    writeln () ;

    for i : = 1 to t do

    begin

    readln (k) ;

    if (k > 0) then

    begin

    d1 + = k;

    d + = 1;

    end;

    end;

    writeln (d1 / d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для Паскаль Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для Паскаль Найдите самую низкую температуру за время наблюдения, если температура опускалась нижу 15 градусов, выведите да, иначе - нет. Программа получает на входе количество дней, а для каждого дня вводится температура.
Ответы (1)
Исполнитель "Умник" получает на входе число, обрабатывает его, и на выходе выдает другое число. Например: на входе 100 = на выходе 25; на входе 48 = на выходе 3; на входе 232 = на выходе 29; на входе 448 = на выходе 7.
Ответы (1)
Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)