Задать вопрос
11 октября, 06:17

Помогите с информатикой!

Ввести с клавиатуры координаты двух точек (А и В) на плоскости (вещ. числа). Вычислите длину отрезка АВ.

+1
Ответы (1)
  1. 11 октября, 10:00
    0
    Program Programma;

    Uses crt;

    var xA, xB, yA, yB, D: real;

    Begin clrscr;

    write ('Введите координаты точки A через пробел: ') ;

    readln (xA, yA) ;

    write ('Введите координаты точки B через пробел: ') ;

    readln (xB, yB) ;

    d:=sqrt (sqr (xA-xB) + sqr (yA-yB)) ;

    writeln;

    write ('Длина отрезака AB = ', d:0:3)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с информатикой! Ввести с клавиатуры координаты двух точек (А и В) на плоскости (вещ. числа). Вычислите длину отрезка АВ. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, как должно получиться введите координаты точки а 5.5 3.5 введите координаты точки b 1.5 2 длинна отрезка ab=4.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Ввести с клавиатуры координаты двух точек (а и в) на плоскости (вещественный числа). вычислить длину отрезка АВ. программу нужно написать в паскале
Ответы (1)
Помогите решить задачу на паскале. Дан массив B (n*m). Элементы массива ввести с клавиатуры. Найти сумму элементов, которые больше данного числа A, но меньше данного числа С. Числа A и С ввести с клавиатуры
Ответы (1)