Задать вопрос
3 октября, 05:29

Помогите решить задачу на паскале.

Дан массив B (n*m). Элементы массива ввести с клавиатуры. Найти сумму элементов, которые больше данного числа A, но меньше данного числа С. Числа A и С ввести с клавиатуры

+3
Ответы (1)
  1. 3 октября, 09:14
    0
    Const

    n = 3;

    m = 4;

    Var

    B:array[1 ... n, 1 ... m] of integer;

    i, j, A, C:integer;

    S:real;

    Begin

    WriteLn ('Введите массив B[', n,',', m,']:') ;

    For i: = 1 to n do

    For j: = 1 to m do

    Read (B[i, j]) ;

    Write ('A = ') ; ReadLn (A) ;

    Write ('C = ') ; ReadLn (C) ;

    S:=0;

    For i: = 1 to n do

    For j: = 1 to m do

    if (A
    S:=S+B[i, j];

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу на паскале. Дан массив B (n*m). Элементы массива ввести с клавиатуры. Найти сумму элементов, которые больше данного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)