Задать вопрос
6 мая, 11:55

Задача №2944. Сумма цифр

Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.

Дано трехзначное число. Найдите сумму его цифр.

Пример

Ввод Вывод

179 17

+1
Ответы (2)
  1. 6 мая, 13:40
    0
    Program count;

    uses crt;

    var a, b, c, x:integer;

    begin clrscr;

    write ('Введите 3-значное число: ') ;

    readln (x) ;

    a:=x div 100;

    b: = (x mod 100) div 10;

    c: = x mod 10;

    writeln ('Сумма цифр числа ', x,' равна ', a+b+c) ;

    readln;

    end.
  2. 6 мая, 13:57
    0
    Program vj;

    var x, a, b, c, h:integer;

    begin

    writeln ('трёхзначное число') ;

    readln (x) ;

    a:=x div 100;

    b:=x div 10 mod 10;

    c:=x mod 10;

    h:=a+b+c;

    writeln (' Сумма цифр этого трёхзначного числа=', h)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача №2944. Сумма цифр Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решето Эратосфена в PascalABC Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.
Ответы (1)
Задача №2942. Число десятков двузначного числа Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия. Ввод Вывод 42 4
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Найти сумму чисел в текстовом документе. Почему пишет неизвестный идентификатор. var a, b:integer; begin assign (input,'input. txt') ; reset (input) ; assign (output,'output.
Ответы (1)