Задать вопрос
25 марта, 14:08

Напишите краткий алгоритм нахождения минимального элемента в одномерном массиве

+4
Ответы (1)
  1. 25 марта, 14:29
    0
    Uses

    Crt;

    const

    n = 10;

    var

    a: array[1 ... n] of integer;

    i, min: integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    min : = 1000;

    for i : = 1 to n do

    begin

    a[i] : = Random (100) ;

    Write (a[i], ' ') ;

    if min > a[i] then min : = a[i]

    end;

    Writeln;

    Writeln ('Минимальный элемент равен ', min)

    end.

    Тестовое решение:

    Исходный массив

    32 35 39 60 35 66 44 50 14 77

    Минимальный элемент равен 14
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите краткий алгоритм нахождения минимального элемента в одномерном массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Разработать алгоритм и программу поиска в одномерном массиве минимального и максимального числа. На экран выдать исходный массив, значения и индексы всех чисел, равных максимальному и минимальному элементам массива.
Ответы (1)
Составьте программу вычисления в одномерном массиве минимального элемента и его номера.
Ответы (2)