Задать вопрос
24 января, 19:24

Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.

Входные данные:

Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D < = 1000).

Выходные данные:

Вывести единственное число.

Пример входного файла (input. txt) :

10 1 1 2 3

Пример выходного файла (output. txt) :

14

+3
Ответы (1)
  1. 24 января, 21:52
    0
    var

    n, a, b, c, d: real;

    begin

    try

    assign (input, 'input. txt') ;

    assign (output, 'output. txt') ;

    reset (input) ;

    rewrite (output) ;

    read (input, n, a, b, c, d) ;

    write (output, trunc (a * b * 2 * n * c / d) + 1) ;

    finally

    try

    close (input) ;

    close (output) ;

    except

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача в Pascal! Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг.
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)