Задать вопрос
31 мая, 16:13

Написать программу в Паскале. Предложение состоит из слов, между словами один пробел, а после последнего слова точка. Найти длину самого длинного слова

+4
Ответы (1)
  1. 31 мая, 19:32
    0
    var

    x: array of string;

    y: string;

    begin

    //readln (y) ;

    y : = 'Привет мой дорогой и прекрасный умопомрач мир';

    x : = y. Remove (y. Length - 1). Split (' ') ;

    y : = x[0];

    foreach w: string in x do

    if (y. Length < = w. Length) then

    y : = w;

    writeln (y. Length) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале. Предложение состоит из слов, между словами один пробел, а после последнего слова точка. Найти длину самого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова. Написать программу в Pascal.
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
Написать программу на Паскале АВС. Дана строка, в которой есть точки, запятые, пробелы, тире, слова. В общем, много-много всего. Нужно преобразовать строку по правилам Ворда. То есть 1. между словами один пробел 2.
Ответы (1)
Нахождение самого длинного слова в тексте. Найти самое длинное слово в тексте. Если таких слов несколько, то взять последнее. Написать на Паскале
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)