Задать вопрос
4 марта, 04:53

Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова.

Написать программу в Pascal.

+4
Ответы (1)
  1. 4 марта, 07:03
    0
    Var a, b, c:integer;

    p, n:string;

    begin

    readln (p)

    ; For a:=1 to length (p) do

    begin

    n:=copy (p, a, 1) ;

    If (n=' ') or (n=',') then

    begin

    If b>c then c:=b;

    b:=0

    end

    else

    b:=b+1;

    end;

    If c=0 then c:=b;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова. Написать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Python: 1. Использовать для решения задачи count. Дана строка, состоящая из слов, которые разделенны пробелами. Определить, сколько в ней слов. 2. Дана строка. Заменить в этой строке все буквы h на букву H.
Ответы (2)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)