Задать вопрос
7 октября, 13:53

Нахождение

самого длинного слова в тексте.

Найти самое

длинное слово в тексте. Если таких слов несколько, то взять последнее.

Написать на Паскале

+5
Ответы (1)
  1. 7 октября, 16:46
    0
    var

    x: array of string;

    y: string;

    begin

    readln (y) ;

    x : = y. Split (' ') ;

    y : = x[0];

    foreach w: string in x do

    if (y. Length < = w. Length) then

    y : = w;

    writeln (y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нахождение самого длинного слова в тексте. Найти самое длинное слово в тексте. Если таких слов несколько, то взять последнее. Написать на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
Написать программу в Паскале. Предложение состоит из слов, между словами один пробел, а после последнего слова точка. Найти длину самого длинного слова
Ответы (1)
Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова. Написать программу в Pascal.
Ответы (1)
Какое из приведённых имён удовлетворяет логическому условию: (первая буква согласная ИЛИ последняя буква согласная) И НЕ (последняя буква согласная) ? Если таких слов несколько, укажите самое длинное из них. Выберите один ответ: a. Иван b. Таня c.
Ответы (1)
Какое из приведённых имён удовлетворяет логическому условию: (первая буква согласная И последняя буква согласная) ИЛИ НЕ (последняя буква согласная) ? Если таких слов несколько, укажите самое длинное из них Выберите один ответ: a. Иван b. Марина c.
Ответы (1)