Задать вопрос
7 октября, 14:49

Дан набор ненулевых чисел, признак его завершения число 0. вывести сумму всех положительных четных чисел из данного набора. если требуемые числа отсутсвуют вывести то вывести 0

+5
Ответы (1)
  1. 7 октября, 17:19
    0
    Var a, s:integer;

    begin

    a:=-1;

    while (a0) do begin

    read (a) ;

    if a>0 then s+=a;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан набор ненулевых чисел, признак его завершения число 0. вывести сумму всех положительных четных чисел из данного набора. если требуемые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачки Pascal. Только не с интернета, они там не правильные. 1. Дано целое число N и набор из N вещественных чисел. Вывести сумму и произведение чисел из данного набора 2.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Задача 4. Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)