Задать вопрос
6 марта, 17:59

Помогите решить задачки Pascal. Только не с интернета, они там не правильные.

1. Дано целое число N и набор из N вещественных чисел. Вывести сумму и произведение чисел из данного набора

2. Дано целое число K и набор ненулевых целых чисел; признак его завершения - число 0.

Вывести количество чисел в наборе, меньших K.

+3
Ответы (1)
  1. 6 марта, 20:59
    0
    1.

    var

    N, i: integer;

    a, sum, mul: real;

    begin

    sum : = 0;

    mul : = 1;

    readln (N) ;

    for i : = 1 to N do

    begin

    readln (a) ;

    sum : = sum + a;

    mul : = mul * a;

    end;

    writeln ('Сумма = ', sum) ;

    writeln ('Произведение = ', mul)

    end.

    2.

    var

    K, less: integer;

    a: real;

    begin

    less : = 0;

    readln (K) ;

    readln (a) ;

    while a 0 do

    begin

    if a < K then

    inc (less) ;

    readln (a) ;

    end;

    writeln (less)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачки Pascal. Только не с интернета, они там не правильные. 1. Дано целое число N и набор из N вещественных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан набор ненулевых чисел, признак его завершения число 0. вывести сумму всех положительных четных чисел из данного набора. если требуемые числа отсутсвуют вывести то вывести 0
Ответы (1)
Дано целое число K, а также K наборов ненулевых целых чисел. каждый набор содержит не менее двух элементов, признаком его завершения является число 0. Найти количество наборов, элементы которых растут или убывают. (Pascal ABC)
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Решить задачу на Pascal'е: Дано целое число N и набор из N вещественных чисел. Проверить, образует ли данный набор возрастающую последовательность, если образует, то вывести True, если нет - вывести False
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)