Задать вопрос
17 марта, 17:43

Решить задачу на Pascal'е:

Дано целое число N и набор из N вещественных чисел. Проверить, образует ли данный набор возрастающую последовательность, если образует, то вывести True, если нет - вывести False

+2
Ответы (1)
  1. 17 марта, 18:13
    0
    Program 1;

    var n, i, G, x:real

    readln (n) ;

    G : = true;

    i : = 1;

    read (x) ;

    while (i < = n) and OK do

    begin

    x_pr : = x;

    read (x) ;

    if x_pr > x then G : = false;

    inc (i) end;

    writeln (G)

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу на Pascal'е: Дано целое число N и набор из N вещественных чисел. Проверить, образует ли данный набор возрастающую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
1. Вычислите логические выражения: not true and not false not true or not false not (true or false) not (true and false) 2. Напишите условие нахождения точки a в первом квадранте системы координат, считая ее координаты заданными X переменными x, y.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите решить задачки Pascal. Только не с интернета, они там не правильные. 1. Дано целое число N и набор из N вещественных чисел. Вывести сумму и произведение чисел из данного набора 2.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)