Задать вопрос
19 февраля, 11:58

Написать программу на Паскале АВС.

Дана строка, в которой есть точки, запятые, пробелы, тире, слова. В общем, много-много всего. Нужно преобразовать строку по правилам Ворда. То есть

1. между словами один пробел

2. перед точкой или запятой пробела нет, но после-есть

3. тире выделяется пробелами с двух сторон

Вот и все!

+4
Ответы (1)
  1. 19 февраля, 14:26
    0
    Var s, s1:string; i, p:integer;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    s1:='';

    for i:=1 to length (s) do

    case s[i] of

    ',','.' : s1:=s1+s[i]+' ';

    '-' : s1:=s1+' - ';

    else s1:=s1+s[i];

    end;

    p:=pos (' ', s1) ;

    while p>0 do

    begin delete (s1, p, 1) ; p:=pos (' ', s1) ; end;

    p:=pos (',', s1) ;

    while p>0 do

    begin delete (s1, p, 1) ; p:=pos (',', s1) ; end;

    p:=pos ('.', s1) ;

    while p>0 do

    begin delete (s1, p, 1) ; p:=pos ('.', s1) ; end;

    writeln (s1) ;

    end.

    Пример:

    Введите строку:

    перед точкой или запятой пробела нет, но после - есть.

    перед точкой или запятой пробела нет, но после - есть.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале АВС. Дана строка, в которой есть точки, запятые, пробелы, тире, слова. В общем, много-много всего. Нужно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Выберите верные правила для ввода текста. Выберите несколько из 5 вариантов ответа: 1) Дефис отделяется пробелами с двух сторон, а тире пробелами не отделяется. 2) Между словами ставится один пробел.
Ответы (2)
Пробел ... 1) ставится перед запятой, двоеточием; 2) не ставится перед запятой, двоеточием; 3) ставится перед запятой, двоеточием и за запятой, двоеточием
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)