Задать вопрос
28 июля, 02:20

помогите сделать в паскале! В заданном двумерном массиве поменять местами следующие два

элемента: Два последних отрицательных.

+3
Ответы (1)
  1. 28 июля, 04:07
    0
    Var

    i, j, ip, jp, ipp, jpp:integer;

    a:array[1 ... 5,1 ... 6]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 5 do

    begin

    for j:=1 to 6 do

    begin

    a[i, j]:=random (-5,5) ;

    write (a[i, j]:3) ;

    if a[i, j]<0 then

    begin

    ipp:=ip;

    jpp:=jp;

    ip:=i;

    jp:=j;

    end;

    end;

    writeln;

    end;

    i:=a[ipp, jpp];

    a[ipp, jpp]:=a[ip, jp];

    a[ip, jp]:=i;

    writeln ('Измененный массив:') ;

    for i:=1 to 5 do

    begin

    for j:=1 to 6 do write (a[i, j]:3) ;

    writeln

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «помогите сделать в паскале! В заданном двумерном массиве поменять местами следующие два элемента: Два последних отрицательных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Задачка в паскале. В двумерном массиве G (7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали.
Ответы (1)
Определить, имеется ли в двумерном целочисленном массиве, заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равное B?
Ответы (1)
Определить имеется ли в двумерном целочисленном массиве заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равного В (В свое видимо задавать)
Ответы (1)
Как в двумерном массиве 5*6, заполненным случайными числами. Поменять местами среднюю строку с первой и последней. Помогите!) очень нужен этот кусок, ввод и вывод массива я в состоянии сама написать : D
Ответы (1)