Задать вопрос
28 октября, 15:29

Проверьте, является ли число простым.

Вводится одно число n.

Формат

выходных данных

Необходимо вывести строку prime, если

число простое, или composite, если

число составное.

+2
Ответы (1)
  1. 28 октября, 18:05
    0
    Function IsPrime (x: integer) : boolean;

    var s, n: integer;

    begin

    Result : = x > 1;

    s : = Trunc (Sqrt (x)) + 1;

    n : = 1;

    while (n < s) and Result do begin

    n : = n + 1;

    Result : = Result and (x mod n > 0) ;

    end;

    end;

    var x, s: integer;

    begin

    readln (x) ;

    if IsPrime (x) then

    writeln ('prime')

    else

    writeln ('composite') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Проверьте, является ли число простым. Вводится одно число n. Формат выходных данных Необходимо вывести строку prime, если число простое, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000. Формат выходных данных: Необходимо вывести значение выражения
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Формат выходных данных Необходимо вывести значение наибольшего элемента в массиве.
Ответы (1)