Задать вопрос
25 октября, 21:25

По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000. Формат выходных данных: Необходимо вывести значение выражения

+2
Ответы (1)
  1. 25 октября, 23:41
    0
    Program Zadacha1;

    Var n: LongInt;

    i: Integer;

    r, a: Real;

    Begin

    Write ('n = ') ;

    ReadLn (n) ;

    If n > 100000 Then

    WriteLn ('Ошибка!')

    Else

    Begin

    r : = 0;

    For i : = 0 To n Do

    Begin

    r : = r + a;

    a : = (1 - (i and 1) shl 1) * (1 / Abs (i * 2 + 1)) ;

    End;

    WriteLn ('Результат: ', r) ;

    End;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
Требуется подсчитать, на сколько минут раньше будет заканчиваться k-й урок, если все перемены сократить на 5 минут. Формат входных данных: Вводится одно натуральное число k, не превосходящее 7.
Ответы (2)
Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее 30000. Формат вывода: Целое число. Пример входных данных 321 Пример выходных данных 1
Ответы (1)
Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Формат выходных данных Необходимо вывести значение наибольшего элемента в массиве.
Ответы (1)