Задать вопрос
3 июня, 20:52

Паскаль

Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива.

Формат выходных данных

Необходимо вывести значение наибольшего элемента в массиве.

+4
Ответы (1)
  1. 3 июня, 22:14
    0
    Program gtr;

    var a:array[1 ... 1000]of integer;

    n, i, max:integer;

    begin

    read (n) ;

    for i:=1 to n do

    read (a[i]) ;

    max:=a[1];

    for i:=2 to n do

    if (a[i]>max) then max:=a[i];

    writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)