Задать вопрос
19 октября, 09:40

Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может взять себе не больше половины огорода (размеры участков после раздела должны быть целыми и участки прямоугольными). Вывести '1' - если участок деда оказался меньше, '0' - если участки равны.

Входные данные:

Во входном потоке в первой строке заданы целые числа A, B (A, B < 1000).

Выходные данные:

Вывести единственное целое число.

Пример входного файла (input. txt) :

8 4

+3
Ответы (1)
  1. 19 октября, 11:28
    0
    Из условия неясно, как определяются размеры участков огорода - линейными размерами или площадью. Т. е. что должно быть целым - линейные размеры или площадь? Будем считать, что целыми должны быть линейные размеры.

    Это означает, что достаточно среди чисел А и В найти четное и разделить его пополам. В этом случае участок деда будет равен половине огорода. Если оба числа нечетных, деду достанется меньше половины огорода.

    var

    A, B:integer;

    f:Text;

    begin

    Assign (f,'input. txt') ;

    Reset (f) ;

    readln (f, A, B) ;

    writeln ('Размеры участка ', A,', ', B) ;

    if (A mod 2=0) or (B mod 2=0) then writeln ('0')

    else writeln ('1')

    end.

    Результат решения:

    Размеры участка 8, 4

    0
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
За день машина проезжает n километров. Сколько дней нужно, чтобы проехать маршрут длиной m километров? Входные данные: Во входном потоке в первой строке через пробел заданы целые значения N и M, значения которых не превышает 30000.
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)