Задать вопрос
8 июля, 17:36

Смурфетта сшила шапки для своих братьев. На первую шапку она потратила 4 часа, на каждую следующую шапку она тратила на 10 минут меньше. Сколько времени она потратил на N шапок? Составить программу на паскале.

+4
Ответы (1)
  1. 8 июля, 19:25
    0
    Var sum, i, n, mins:integer;

    begin

    read (n) ;

    mins:=4*60;

    sum:=0

    for i:=1 to n do begin

    sum : = sum + mins;

    mins : = mins - 10;

    end;

    writeln ('minut potracheno:', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Смурфетта сшила шапки для своих братьев. На первую шапку она потратила 4 часа, на каждую следующую шапку она тратила на 10 минут меньше. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите, с помощью паскаля надо сделать следующее: Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Ответы (1)
1. Каков будет рост ребенка через год, если за месяц он подрастает на 2% по сравнению с предыдущим. Рост в начале года 120 см. 2. В течение недели мама ежедневно ходила на рынок и тратила на 5 рублей больше, чем в предыдущий.
Ответы (2)
1) написать программу На столе стоит 10 кастрюль, которые необходимо заполнить водой. В первую кастрюлю помещается 0,5 литра воды, а в каждую следующую на 0,5 литра больше, чем в предыдущую. Сколько воды потребуется для заполнения всех кастрюль?
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)