Задать вопрос
16 апреля, 11:07

1. Каков будет рост ребенка через год, если за месяц он подрастает на 2% по сравнению с предыдущим. Рост в начале года 120 см.

2. В течение недели мама ежедневно ходила на рынок и тратила на 5 рублей больше, чем в предыдущий. Написать программу, подсчитать расход за неделю, если в первый день она потратила 100 р.

Паскаль

+1
Ответы (2)
  1. 16 апреля, 13:18
    0
    Var

    var

    P, x:real;

    begin

    P:=120;

    while P<=120 do

    begin

    P:=P+0.02*P;

    x:=x+1;

    end;

    write ('Ребёнок подрастёт за:', x,' ','месяцев') ;

    end.
  2. 16 апреля, 14:34
    0
    Var i:integer;

    r:real;

    begin

    r:=120;

    for i:=1 to 12 do

    r:=r+r*0.02;

    writeln (r:3:2) ;

    end.

    var a, i:integer;

    begin

    for i:=1 to 7 do

    a:=a+5;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Каков будет рост ребенка через год, если за месяц он подрастает на 2% по сравнению с предыдущим. Рост в начале года 120 см. 2. В течение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Рост ребенка на начало года 120 см. за месяц он подрастает на 2%. через сколько месяцев рост ребенка превиысит 150 см?
Ответы (2)
Рост ребенка на начало года составляет 120 см. За месяц он подрастает на 2%. За сколько месяцев его рост станет больше или равным 150 см.
Ответы (1)
Смурфетта сшила шапки для своих братьев. На первую шапку она потратила 4 часа, на каждую следующую шапку она тратила на 10 минут меньше. Сколько времени она потратил на N шапок? Составить программу на паскале.
Ответы (1)
Нужно составить программу в паскале Царевна-лягушка съедает ежедневно на 20 % комаров больше, чем в предыдущий день, и еще 2 комара. Через сколько дней количество съеденных комаров в день превысит 100, если в первый день было съедено 12 комаров.
Ответы (1)