Задать вопрос
29 сентября, 18:43

Здраствуйте) Прошу помочь! Мне нужно решить задачу, расписав её для паскаля, прошу очень подробно! Вот сама задача - Дан массив из N элементов. Написать программу, уменьшающую все элементы массива на единицу.

+5
Ответы (1)
  1. 29 сентября, 19:44
    0
    Var a: array of integer; / / Объявление массива целых чисел

    i, n: integer; / / объявление целочисленных переменных

    begin

    / / Запросим с клавиатуры размер массива

    / / и запишем его в переменную n

    write ('введите n:') ;

    readln (n) ;

    / / Теперь выделим память под n элементов массива

    SetLength (a, n) ;

    / / теперь запросим с клавиатуры n чисел для массива

    for i : = 0 to n-1 do begin

    write ('a[', i, ']=') ;

    readln (a[i]) ;

    end;

    / / теперь в цикле уменьшим каждый элемент на единицу

    for i : = 0 to n-1 do

    a[i] : = a[i] - 1;

    / / распечатаем массив

    for i : = 0 to n-1 do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Здраствуйте) Прошу помочь! Мне нужно решить задачу, расписав её для паскаля, прошу очень подробно! Вот сама задача - Дан массив из N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)