Задать вопрос
23 апреля, 20:25

Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив. Для перехода на новую строку добавить writeln.

Это все в pascal abc

+2
Ответы (1)
  1. 23 апреля, 22:16
    0
    Const n=10000;

    var a:array [1 ... n] of integer;

    b:array [1 ... n] of integer;

    i, k:integer;

    begin

    Writeln ('Введите число элементов массива') ;

    readln (k) ;

    for i:=1 to k do begin

    Writeln ('Введите ', i,' элемент массива') ; readln (a[i]) ; end;

    for i:=1 to k do begin b[i]:=a[i]-1; end;

    Writeln ('Первоначальный массив:') ;

    for i:=1 to k do begin writeln (a[i]) ; end;

    Writeln ('Конечный массив:') ;

    for i:=1 to k do begin writeln (b[i]) ; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)