Задать вопрос
22 ноября, 16:52

Дана строка, содержащая английский текст. Найти количество слов, начинающихся с буквы d.

+5
Ответы (1)
  1. 22 ноября, 17:03
    0
    Var

    s: string;

    p, nb: integer;

    begin

    write ('text? ') ;

    readln (s) ;

    p : = 1;

    while p < = length (s) do begin

    while (s[p] = ' ') and (p < = length (s)) do inc (p) ;

    if (p < = length (s)) and (s[p] = 'b') then inc (nb) ;

    while (s[p] ' ') and (p < = length (s)) do inc (p) ;

    end;

    write ('num words: ', nb) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, содержащая английский текст. Найти количество слов, начинающихся с буквы d. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Написать программу на Python: 1. Использовать для решения задачи count. Дана строка, состоящая из слов, которые разделенны пробелами. Определить, сколько в ней слов. 2. Дана строка. Заменить в этой строке все буквы h на букву H.
Ответы (2)