Задать вопрос
21 января, 09:12

Определить количество отрицательных элементов матрицы

+1
Ответы (1)
  1. 21 января, 12:37
    0
    Const n=5;

    Var a:array [1 ... n, 1 ... n] of integer; i, j, k:integer;

    Begin

    for i:=1 to n do

    for j:=1 to n do begin

    readln (a[i, j]) ;

    if a[i, j]<0 then inc (k) ; end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить количество отрицательных элементов матрицы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Матрицы. Вычислить произведение отрицательных элементов вещественной матрицы Bnxn, находящихся под главной диагональю (элементы диагонали не участвуют в обработке).
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
Разработать алгоритм и программу решения задачи: найти сумму отрицательных элементов двумерного массива находящихся на главной диагонали матрицы размером 10 х10 (с вводом и выводом матрицы)
Ответы (1)
Дана матрица А (3,3), найти количество положительных элементов матрицы, сформировать новую матрицу Х (3,4), элементы которой получены из элемнтов А путём деления их на найденное количество. Матрицы А и Х вывести по строкам
Ответы (1)