Задать вопрос
11 декабря, 18:04

Записать, как програму в паскале

Дана последовательность чисел, оканчивающихся нулем. Найти произведение чисел, оканчивающихся цифрой 5.

+2
Ответы (1)
  1. 11 декабря, 21:49
    0
    Var

    x, p: longint;

    begin

    Writeln ('Вводите через пробел натуральные числа, 0 - конец ввода') ;

    p : = 1;

    repeat

    Read (x) ;

    if x 0 then

    if (x mod 5) = 0 then p : = p * x

    until x = 0;

    Writeln ('Произведение чисел, оканчивающихся цифрой 5, равно ', p)

    end.

    Тестовое решение:

    Вводите через пробел натуральные числа, 0 - конец ввода

    3 4 15 7 25 2 5 0

    Произведение чисел, оканчивающихся цифрой 5, равно 1875
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем. Найти произведение чисел, оканчивающихся цифрой 5. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)
Дана последовательность чисел, заканчивающаяся нулем. найти сумму отрицательных и произведение положительных чисел. Напишите в паскале
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)
Дана последовательность чисел оканчивающихся на 0 найти сумму и произведение этих чисел (Нужно написать программу в Паскале
Ответы (1)