Задать вопрос
15 марта, 22:50

Дана последовательность чисел, заканчивающаяся нулем. найти сумму отрицательных и произведение положительных чисел. Напишите в паскале

+1
Ответы (1)
  1. 16 марта, 02:17
    0
    Program a;

    var i, s, r:integer;

    begin

    s:=1;

    read (i) ;

    while i0 do

    begin

    if (i<0) and (i0) then r:=r+1 else s:=s*i;

    read (i) ;

    end;

    writeln (s, r) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел, заканчивающаяся нулем. найти сумму отрицательных и произведение положительных чисел. Напишите в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Дана не пустая последовательность чисел заканчивающаяся нулем. Найти максимум.
Ответы (1)
дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)