Задать вопрос
1 сентября, 05:03

дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности

+2
Ответы (1)
  1. 1 сентября, 05:15
    0
    На паскале

    program m1;

    var a: aarray [1 ... 10] of integer;

    i, n, k: integer;

    begin

    readln (n) ;

    for i: = 1 to n do readln (a[i]) ;

    k: = 0;

    for i: = 1 to n do begin

    if a[i]0 then k: = k+1;

    end;

    writeln (k) {если 0 нужно учитывать в количестве то ... } writeln (k+1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Задача 4. Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)