Задать вопрос
13 мая, 14:10

Дана не пустая последовательность чисел заканчивающаяся нулем. Найти максимум.

+5
Ответы (1)
  1. 13 мая, 16:21
    0
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 program cnt; var x, n, k : integer; begin n : = 1; {nomer elementa posledovatelnosti} k : = 0; {kolichestvo chetnyh elementov s nomerami, kratnym 5} writeln ('введите число') ; repeat begin readln (x) ; if (x mod 2 = 0) and (n mod 5 = 0) then inc (k) ; n : = n + 1; end; until x = 0; writeln ('k=', k) ; readln; end.

    За это 5 получил!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана не пустая последовательность чисел заканчивающаяся нулем. Найти максимум. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность чисел, заканчивающаяся нулем. найти сумму отрицательных и произведение положительных чисел. Напишите в паскале
Ответы (1)
дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности
Ответы (1)
Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).
Ответы (1)
Минимум-Максимум. На вход программе подается последовательность целых чисел, заканчивающаяся 0. Видитет минимальное и максимальное значение среди чисел этой последовательности, 0 при этом не учитывается. При решении задачи массив использовать нельзя.
Ответы (1)
Паскаль: Дана последовательность целых положительных чисел, заканчивающаяся числом, разряд единиц которого равен нулю. Определите, сколько чисел в последовательности, не считая данного числа.
Ответы (1)