Задать вопрос
17 марта, 20:34

Дана последовательность чисел оканчивающихся на 0 найти сумму и произведение этих чисел (Нужно написать программу в Паскале

+2
Ответы (1)
  1. 17 марта, 22:28
    0
    Var a, s, p:integer;

    begin

    s:=0;

    p:=1;

    write ('Введите число: ') ;

    readln (a) ;

    while a0 do

    begin

    s:=s+a;

    p:=p*a;

    write ('Введите число: ') ;

    readln (a)

    end;

    writeln ('Сумма чисел в последовательности: ', s) ;

    writeln ('Произведение чисел в последовательности: ', p)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел оканчивающихся на 0 найти сумму и произведение этих чисел (Нужно написать программу в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем. Найти произведение чисел, оканчивающихся цифрой 5.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0.
Ответы (1)
Нужно написать программу на PascalABC Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)