Задать вопрос
4 октября, 22:56

Составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20; 30]

+2
Ответы (1)
  1. 5 октября, 02:54
    0
    Program Task;

    Const n = 15;

    Var a: Array [1 ... n] of Integer;

    i: Integer;

    Begin

    Randomize;

    For i : = 1 To n Do

    a[i] : = Random (30 - 20 + 1) + 20;

    WriteLn ('Массив:') ;

    For i : = 1 To n Do

    Write (a[i], ' ') ;

    WriteLn;

    For i : = 1 To n Do

    If a[i] Mod 2 = 1 Then

    a[i] : = 31;

    WriteLn ('Результат:') ;

    For i : = 1 To n Do

    Write (a[i], ' ') ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20; 30] ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)
Составить программу, которая формирует массив из 12 случайных чисел, принадлежащих промежутку [-10,10], заменяет все отрицательные числа положительными, а положительные заменяет на ноль.
Ответы (1)
Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количество замен.
Ответы (1)
1) дан числовой массив из 10 чисел (случайным образом) в интервале (50, 250). Отсортировать массив. 2) В компьютер вводится результат для 10 абитуриентов.
Ответы (1)