Задать вопрос
18 октября, 18:51

Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количество замен. Протестировать программу на следующих исходных данных: а) Z=10 Массив: 1,2 2,6 3 - 4,5 11 10,2 3,2 87 - 15 б) Z=-2 Массив: 0 - 3,1 11 - 7,9 - 2,1 - 1,9 4

+5
Ответы (1)
  1. 18 октября, 19:51
    0
    const

    n=10;

    var

    a:array [1 ... n] of real;

    z, i, k:integer;

    begin

    for i:=1 to n do

    begin

    write ('A[', i,'] = ') ; readln (a[i]) ;

    end;

    write ('Z = ') ; readln (z) ;

    for i:=1 to n do

    if a[i]>z then begin

    a[i]:=z;

    k:=k+1;

    end;

    for i:=1 to n do

    if frac (a[i]) = 0 then write (a[i]:0:0,' ') else write (a[i]:0:1,' ') ;

    writeln ('Kol-vo zamen: ', k) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Напишите программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных: а) k=3 Массив: 2 6 - 9 4 5 12 - 15 б) k=4 Массив: 9 0 8 124 - 16 11 19
Ответы (1)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
4. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах: а) 1 3 4 - 2 б) 0 1 - 2 10 11 12 - 10 - 3 в) 1 1 1 1 - 1 - 1 - 1 - 1
Ответы (1)