Задать вопрос
1 марта, 16:05

4. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах:

а) 1 3 4 - 2

б) 0 1 - 2 10 11 12 - 10 - 3

в) 1 1 1 1 - 1 - 1 - 1 - 1

+3
Ответы (1)
  1. 1 марта, 16:40
    0
    Program n1;

    const n=10;

    var a: array [1 ... n] of integer;

    i, sum: integer;

    begin

    sum:=0;

    for i:=1 to n do

    begin

    write ('введите ', i,' число: ') ;

    readln (a[i]) ;

    end;

    writeln ('массив: ') ;

    for i:=1 to n do begin

    sum:=sum+a[i];

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('сумма: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)
Написать программу, которая вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать: программу на поизвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.
Ответы (1)
3. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать программу на произвольных массивах размерностью 5 и 8 элементов.
Ответы (1)
Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.
Ответы (1)