Задать вопрос
10 сентября, 20:07

доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику.

1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать программу на произвольных массивах размерностью 5 и 8 элементов.

2 ... Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах:

а) 1 3 4 - 2

б) 0 1 - 2 10 11 12 - 10 - 3

в) 1 1 1 1 - 1 - 1 - 1 - 1

очень прошу-у-у, уделите время, если Вас не затруднит.

+5
Ответы (1)
  1. 11 сентября, 00:04
    0
    1)

    var a:array [1 ... 100] of integer; объявляем массив

    i, n:byte; объявляем вспомогательную переменную i и переменную n для хранения количества элементов

    begin

    write ('Введите n = ') ; readln (n) ; вводим n

    for i:=1 to n do begin от 1 до n цикл

    write ('a[', i,']=') ;

    readln (a[i]) ; вводим элементы в массив

    end;

    write ('Исходный массив: ') ;

    for i:=1 to n do выводим наш массив полностью

    write (a[i],' ') ;

    writeln;

    write ('Результат: ') ; выводим результат, в данном случае все элементы стоящие на четных местах

    for i:=1 to n do

    if i mod 2 = 0 then write (a[i],' ') ; проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

    end.

    2)

    var a:array [1 ... 100] of integer;

    i, n:byte; s:longint; s объявляем для хранения суммы элементов

    begin

    s:=0; обнуляем s

    write ('Введите n = ') ; readln (n) ; тут тоже самое, что и в первой задаче

    for i:=1 to n do begin

    write ('a[', i,']=') ;

    readln (a[i]) ;

    s:=s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

    end;

    write ('Исходный массив: ') ;

    for i:=1 to n do вывод массива

    write (a[i],' ') ;

    writeln ('Сумма всех элементов массива = ', s) ; вывод суммы

    end.

    Удачи=)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
3. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать программу на произвольных массивах размерностью 5 и 8 элементов.
Ответы (1)
4. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах: а) 1 3 4 - 2 б) 0 1 - 2 10 11 12 - 10 - 3 в) 1 1 1 1 - 1 - 1 - 1 - 1
Ответы (1)
Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)