Задать вопрос
16 июня, 07:38

Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел)

+1
Ответы (2)
  1. 16 июня, 08:26
    0
    Program ufhg;

    uses crt;

    var a, b, c, d, m: integer;

    begin

    readln (a, b, c, d) ;

    m:=a;

    if (b>m) then m:=b;

    if (c>m) then m:=c;

    if (d>m) then m:=d;

    writeln (m) ;

    end.
  2. 16 июня, 08:37
    0
    Var

    a, b, c, d: integer;

    function max (i1, i2: integer) : integer;

    begin

    if i1 > i2 then max : = i1 else max : = i2;

    end;

    begin

    read (a, b, c, d) ;

    writeln (max (max (max (a, b), c), d)) ;

    end.

    не помню как процедуры писать, но с функциями даже удобнее
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Описать процедуру SumDigit (N, S), находящую сумму цифр S целого числа N (N - входной, S - выходной параметр). Используя эту процедуру, найти суммы цифр пяти данных чисел.
Ответы (1)
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа. Используйте пригласительную строку. Используйте процедуру очистки экрана (для ТП).
Ответы (1)